404 Error when Upgrading Parrot OS

On 10/8/21, I installed a fresh version of Parrot OS, 4.11.2. Upon install, I ran the command “sudo apt clean”, “sudo apt update”, “sudo apt full-upgrade -y”. However, I was unable to upgrade the packages on my computer and there were 404 not found errors. I then ran “sudo apt update --fix-missing” and then “sudo apt full-upgrade -y”. Still it did not work. Today, 11/8/21, I tried to upgrade the packages but I faced the same problems. What should I do now?

It could be a mirror problem, try to use others, there is a list in the documentation. In any case, use sudo parrot-upgrade instead of all those commands.

Same Issue… It shows the package exists in remote dir / mirror [for example here https://deb.parrot.sh/parrot/pool/main/e/element-desktop/ ]

But when you try to download it says 404 file not found

bro use risen up vpn and try it again
it just a mirror problem i have done same and it’s worked fine

same problem

bump to this thread, I’m also having the same issue. I’ve tried all the advice above.

I was having update/install errors for about the last 2 months. The default mirror (redirect) isn’t working:

deb https://deb.parrot.sh/parrot/ rolling main contrib non-free
#deb-src https://deb.parrot.sh/parrot/ rolling main contrib non-free
deb https://deb.parrot.sh/parrot/ rolling-security main contrib non-free
#deb-src https://deb.parrot.sh/parrot/ rolling-security main contrib non-free

I started using a mirror in China, then in Italy to get it working.

http://mirrors.tuna.tsinghua.edu.cn/parrot

http://parrot.mirror.garr.it/mirrors/parrot

Here is a list of different mirrors to try. I think all the U.S. ones are broken.

https://www.parrotsec.org/docs/mirrors-list.html

Parrot repo is a normal right now, just try again.
this is my parrot repository

## stable repository
deb https://deb.parrot.sh/parrot rolling main contrib non-free
deb https://deb.parrot.sh/parrot rolling-security main contrib non-free
#deb-src https://deb.parrot.sh/parrot rolling main contrib non-free
#deb-src https://deb.parrot.sh/parrot rolling-security main contrib non-freetype or paste code here

What country are you in Afiadi? I believe https://deb.parrot.sh/parrot is a redirect mirror to a local server in the user’s country.

hello
i am facing this upgrading problem from 1 week (i newly installed parrot mate) whenever I tried to use apt update it shows me 8 files to upgrade, but when i use sudo apt full-upgrade then i got this 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
when I check sudo apt list --upgradable
Listing… Done
lib32stdc++6/rolling 11.2.0-5 amd64 [upgradable from: 10.2.1-6]
libasan6/rolling 11.2.0-5 amd64 [upgradable from: 10.2.1-6]
libgomp1/rolling 11.2.0-5 amd64 [upgradable from: 10.2.1-6]
liblsan0/rolling 11.2.0-5 amd64 [upgradable from: 10.2.1-6]
libstdc++6/rolling 11.2.0-5 amd64 [upgradable from: 10.2.1-6]
libtsan0/rolling 11.2.0-5 amd64 [upgradable from: 10.2.1-6]
libubsan1/rolling 11.2.0-5 amd64 [upgradable from: 10.2.1-6]
rustc/rolling 1.49.0+dfsg1-1+b1 amd64 [upgradable from: 1.48.0+dfsg1-2]

I dont know what’s wrong with my os can you please help me if possible.

Thanks in advance

Yeah, I’ve been seeing this for awhile too. Things like this happen on Parrot occasionally. The developers are probably holding these updates back while they work on an associated package. We just have to wait.

Hola de nuevo. ¿Y alguien sabe cómo se hace el cambio de repositorio? mientras esperamos que el equipo de Parrot pueda solucionar lo del repositorio que no funciona.

sudo nano /etc/apt/sources.list.d/parrot.list

In my system parrot os is working normal and works flawlessly to check update to list upgrade, and to parrot-uipgrade. I use default parrot mirrors. With use default parrot mirros, parrot search and redirect to nearest repo from your or my location.

Exactly: my local mirrors were broken. Which is why I had to try out different mirrors in other countries.

1 Like

Are you Parroting (hehe) exactly what I suggested you do above?

something is wrong with rsync’s cronjob

1 Like