Anonsurf problem. .

Briefly describe your issue below:
I am having an anonsurf issue, I click start from the dropdown menu and enter my password for root and it doesn’t assign me an IP and connect to the TOR network. I have no other anonymizers installed but I have tried others and they don’t seem to work anyways. I have tried to manually start the tor service and then run anonsurf and I’ve had no luck. I’ve even tried to manually install anonsurf from the github and run the script and still no luck. Someone on an earlier version of parrot sec os fixed the issue of deleting the iptables?? But didn’t give a description on how to do so.

What version of Parrot are you running? (include version, edition, and architecture)
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:
If there are any error messages or relevant logs, post them below:

You Can Upgrade Your System
apt-get upgrade

Mm Ok Do This First
No From That Button Work Only In Root User
Sudo Command Not Working Fo It

Enter Your Root Password
anonsurf start
For stop
anonsurf stop

If Not Want To Do This Here Is
In VPN Part , There Is Option I Added