Can't connect to Internet when anonsurf is disabled

Briefly describe your issue below:
I installed Parrot on 3 May
I cannot connect to the internet without enabling anonsurf.
Wifi/Ethernet shows connected.
Also can’t update/upgrade while anonsurf is ON

What version of Parrot are you running?
Version 4.9
Edition: Security MATE

What method did you use to install Parrot?
Live Boot -> Install

Configured to multiboot with other systems?
Yes (Windows 10)

List your networking hardware (make, model, firmware version):
Ethernet: Realtek RTL8111/8168/8411 PCI Express
Wifi: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adaptor
(Laptop HP 15s-dr0xxx)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
ping 8.8.8.8 (working)
ping 192.168.0.1 (working)
ping www.google.com (Temporary failure in name resolution)
cat /etc/resolv.conf (No such file or directory) {Also the resolv.conf in /etc directory is marked in red}

Welcome to the forums @PraSar :slight_smile:

I cannot connect to the internet without enabling anonsurf.

Dns is not resolving. If you are missing /etc/resolv.conf entirely, this sounds like the issue.

First let’s make sure all possible anonsurf features are completely reversed. Enter this as one command (entire line):

sudo anonsurf restart;sudo anonsurf stop

After this let us know the status/content of /etc/resolv.conf and
/etc/resolvconf/run/resolv.conf

Do those 2 locations exist? Reply with the contents of those 2 locations and we will go from there.

1 Like

Thank you for replying.
As I have said /etc/resolv.conf exists only when anonsurf is ON, otherwise it shows: No such file or directory.

/etc/resolvconf/run/resolv.conf does not exist
/etc/resolvconf directory has the following entries:
interface-order(file), resolv.conf.d(dir), update.d(dir), update-libc.d(dir)

the exact same problem occurred in my laptop which is installed parrot security os 4.9.
these somehow may be caused by the uninteneded behaviour of anonsurf when shutting down the computer without turning off anonsurf!
anonsurf won’t reset the internet relating setting in the computer when shutting down.
so need to reset internet setting such as like dns etc

in my case, after running “sudo dpkg-reconfigure resolvconf” on the terminal worked wifi properly again.

I’m sorry i found the above-mentioned topic somewhere on the internet aber i’ve lost the address so i can’t import its contents.
i’m hoping this method works as well as in your computer, emacipating parrot from wifi problem cage

2 Likes

Fixed this bug. I just noticed it.

1 Like

It should be solved in latest version by using systemd unit. I have to check the source code again to make sure there is no logic problem.

You can run sudo resolvconf -u

1 Like

I added a tool called dns tool can fix it easily. It can be fixed by running sudo dnstool static opennic :smiley: or sudo dnstool static 8.8.8.8

3 Likes

Thanks for replying.
And sorry for replying late.

I have fixed my problem using ‘dpkg-reconfigure resolvconf’.

thank you brother… second command worked for me… <3

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.