Can't find/boot Windows 10

Briefly describe your issue below:
I swear I searched first, but I am unable to open Windows after my install.

What version of Parrot are you running? (include version, edition, and architecture)
4.5.1 Live+Installer Security Edition 64bit

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Live mode to standard installer

Configured to multiboot with other systems? (yes / no)
Yes, Windows 10

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

You cant boot to it by selecting it in the bios or it doesnt show up in grub?

It shows up in bios, and if I try to change my boot order, it just takes me to the Windows troubleshooting screen. In grub, it just shows the Windows Boot Manager but will not start up from that selection.

Try running sudo update-grub. Then rebooting, see if windows boots then.

Have you tried going through windows troubleshooting and seeing what it diagnoses?

Parrot wont modify any drives, outside of the ones you select during installation. Are you sure you didnt accidentally install over part of your windows drive?

1 Like

I tried Windows troubleshooting, it just says the problem can not be resolved. I actually tried every option within the troubleshooter, even going as far as trying to delete all files with the exception of personal ones. I get a response that the action can not be completed.

Unfortunately I am not. I have a 3 year old, who happened to see my computer and go through some of the installation for me by pressing buttons. While I am a fan of her interest, I wish she had taken the initiative on her play laptop.

Ah, well you can always use gparted to inspect the partitions.
It sounds like you might have installed over your windows partition, but not your recovery partition. Hence the ability to enter windows recovery, but not boot the OS.

1 Like

At the end of my post, I placed a link to a few photos of my screens and gparted as well. If you could take a look and offer up a suggestion, it would be greatly appreciated.

Sorry, but there doesnt appear to be a windows operating system on that drive.

There should be a partition using the ‘ntfs’ file system, with the label ‘OS’ and the flag ‘msftdata’.

You could still try to recover some of the data.

1 Like

I really only need the D: drive that I have, the C: drive was just there to boot Windows and Parrot. Do you think it would be feasible to use a Windows key, or could I recover the Boot option another way?

Im not sure what you mean. Recover boot option?

Sorry, I am trying to respond between service calls.
My C: drive was only used as the Windows boot drive, hence wanting to use that drive for Parrot as well. My D: drive is where I kept anything that was actually in use. Work files, games, photos, things like that. So I am wondering if there is any way to recover Windows at all from the C: drive, or since I am able to boot it into a mode that provides troubleshooting options, could I use a windows key or bootable usb to attempt a reinstall. Or, would it be possible to start windows from the D: drive, even if that is not where my OS was located?

You can reinstall windows on C: yeah. Although windows likes to mess up linux distributions when you install windows after linux. But if you only just installed parrot it wouldnt be the end of the world if you had to reinstall.

You cant boot your D: drive no.

I though windows keys were tied to accounts nowadays, so when you signed in it applied (Check first if you do that). There may be other ways of recovering your windows key, but you would have to ask Microsoft support.

1 Like

I was also thinking they were tied into accounts, just have not had to worry about it in quite some time. Thanks for the help, its appreciated.

1 Like

Hi. So if your grub doesn’t show windows you may try running sudo os-prober.

Though even if os-prober doesn’t find your windows, it means that there’s no boot file for it and you have to recover it manually. You can do that by mounting your C:/ partition and grabbing boot file from it, then mounting EFI partition and copy that file there. Though it sounds crazy, it’s not that hard.

All these commands have to be done in live mode.

  1. You have to find out where’s your Windows C:/ partition. Run sudo lsblk and guess it by size, or run GParted and find out what is the number of partition (i. e. /dev/sda3 or /dev/nvmen1p1).
  2. After you find out partition number, you have to mount it in order to grab the file. Let’s assume that your partition is /dev/sda4. That’s what you need to do:

sudo mount /dev/sda4 /mnt - this will mount your C:/ windows partition in read-only mode;
cp -r /mnt/Windows/Boot/EFI ~/EFI-BACKUP - this will copy a copy of microsoft boot folder in your home (~) folder;
sudo umount /mnt - unmount windows partition;

  1. Now when you have efi backup folder you have to mount EFI partition and copy it there. Run sudo lsblk again and find your EFI partition (usually it’s in top and around 100-500 MB)

Let’s say your EFI partition is /dev/sda2/:

sudo mount /dev/sda2 /mnt - mounts your EFI partition;
cp -r ~/EFI-BACKUP /mnt/EFI/Microsoft/Boot - copies windows boot files to EFI;
sudo umount /mnt - unmounts your EFI partition.

  1. Now you may run sudo os-prober again, and if it finds a windows boot manager run sudo update-grub2.
1 Like

I’ll give it a shot right now.

I supposes it is windows 10
Boot in windows boot manager option
Go to cmd

And run
bootrec /fixmbr
&& after that auto troubleshoot option
Then restart

that actually can kill grub as it will rewrite efi partition.

I know , after that just need to again
Boot in live Linux and fix Linux grub

The product key is linked to a particular machine and with a microsoft a machine may be associated with an account but not for activation tracking. You probably wont need a product key, nowadays those keys are stored in some nvram/bios/cmos location. Just let the windows installer handle everything and all should be well. There’s also supposed to be sticker somewhere on machine but depending on how you bought and/or activated the machine it may or may not work.

Had the same problem when i’ve installed Parrot for the 1st time - in my case i’ve installed the GRUB incorrect. The solution was easy - reinstall it, but i think some guys here told You here about it already :frowning: (or maybe not?)