error no openvas scanner found.

– Please Write here your help request, –

—hello how are you I have a problem with parrot v5 I can not use openvas because it says that the scanner is not installed I searched everywhere how to do it and nothing is working who can help me with this application.

  • Parrot version in use (if you are not aware of it, open terminal and type cat /etc/os-release | grep VERSION):

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:

It changed the name to gvm. If you have any error when install gvm, just send screenshot here and i’ll check.

thanks for the answer i have this version.
VERSION_ID=“5.0”
VERSION=“5.0 (Electro Ara)”
VERSION_CODENAME=ara

sudo gvm-check-setup
gvm-check-setup 21.4.3
Test completeness and readiness of GVM-21.4.3
Step 1: Checking OpenVAS (Scanner)…
ERROR: No OpenVAS Scanner found.
FIX: Please install OpenVAS Scanner.

ERROR: Your GVM-21.4.3 installation is not yet complete!

Please follow the instructions marked with FIX above and run this
script again.

Testing in vbox :slight_smile: I’ll response asap

FYI: This problem has been noted in several posts over the last month or two. :+1:

I included a webpage in the following post that helped me get things working under a different distro.

I think this’s different. The error wasn’t redis server but missing lib. openvas: error while loading shared libraries: libopenvas_nasl.so.21: cannot open shared object file: No such file or directory


The libs look good. still debugging

Add LD_LIBRARY_PATH=/usr/lib64/ to run openvas commands / binaries could be a solution but to make it work with the whole openvas services is something i’m trying to figure out

On Parrot 5.0 I get to that point above.

On Kali I have it working.

Greetings, thank you for responding, thank you very much, I had version 3.1 of parrot os and openvas works well in 3.1 but I changed to 5 and it doesn’t work I did a new installation to version 5 and openvas doesn’t work for me I think version 5 of parrot os has that problem and it doesn’t allow complete installation of openvas, in kali openvas works well I don’t know why here in parrot os v5 it doesn’t work. I would like to use parro because I want to start class in vase to parrot but I need everything to work well.

What version Kali is having?
I updated gvm to 21.4.4 on Parrot but the problem wasn’t fixed.

Well it’s similar to Parrot. the current version on parrot repo was rebuilt by Palinuro, cloned from Debain repository so it could be mistake of Palinuro or Debian team. I have to check it

1 Like

It has been a pain to setup OpenVAS/GVM on various distros, taking a lot of tinkering, mainly with Redis and the locations, permissions, and configurations of files. Luckily this page has most of the fixes for recent GVM releases.

I didn’t want to bother Parrot devs about the broken package(s) when Parrot 5.0 came out as it’s difficult to get working without a lot of work even when everything can be finally configured. (I just use GVM to test local systems and occasionally try out Metasploit with found exploits in Metasploitable VMs.)

It’s like Greenbone has purposely made “OpenVAS” difficult on other distros to make people buy their products instead of using the GPL version.

We can’t check all of it, especially runtime problems. We are happy to get some bug reports. Well when i said bug reports, i didn’t mean “hello sar i need halp” topics with no context at all.

I wouldn’t say that. Linux world is a wild world itself. There are too many sides to think of if you want your package just work: compile time packages, runtime packages (which depends on distro); and then distro build method which is not always nice. For example: When i developed new version of anonsurf with systemd, the Debian pkging has dh_systemd and then as far as i can remember right now, they removed that support or changed the structure method. So you don’t really know if your package is broken by just a simple mistake of a simple person.

More about this bug: it seems very simple: GVM runs as a service. It requires compiled libraries and systemd didn’t allow libraries at all, which i suppose something wrong about Env vars. Because Kali is having version 21.4 so it looks like it’s our mistake rather than gvm’s mistake.

LOL! “halp me hak instagam plzzz!!!” - Facebook users on network security groups

Yeah, that’s true. Linux keeps evolving, developers keep changing code which effects other developers downstream. I was studying to take the CompTIA Linux+ (XK0-004), but it’s filled with a lot of the old way of doing things, for example learning Grub and Grub2, Init and Systemd, etc. So I’ll keep using Linux daily and wait for the XK0-005 to drop some of the older topics.

Somewhat related: I’m glad I didn’t get heavily into Macintosh Pascal and assembly programming for the 680x0 processor ~1994. Apple soon switched to the PowerPC processor, then they switched from Mac Classic to Mac OS X, then they switched to Intel processor, now they switched to ARM processor.

Not related: I recently discovered algebraic geometry (a different way to do vector/tensor calculus) and found out game engines (Unreal, Unity) could model algebraic geometry (like quaternions), so I started studying C# for Unity. After about a week I decided before spending too much time deeply diving into C#, I researched what is the recommended programming language for math and physics. So python it is (which I got interested in before dedicating ~3 years while working a demanding job to earn my Cisco CCNA).

I apologize for being chatty and off-topic tonight. :face_with_hand_over_mouth:

Interesting. Hope you can quickly figure out a fix without too much hassle.

LuL that’s real pain. I found out the developers of gintro (gtk binding of Nim) could stop supporting their library. That’s real pain.

I didn’t find any solution. The only “solution” was adding Environment= from documentation. And well… systemd warned it was a syntax error.

I have a same problem. I tried restart ospd-openvas.service but it cannot:
#service ospd-openvas restart
Job for ospd-openvas.service failed because the control process exited with error code.
I tried everything. :slight_smile:
But don’t solved the problem.