External Monitor Hybrid GPU

Briefly describe your issue below:

When trying to use a secondary monitor over HDMI the monitor is not detected. Tried with both nvidia and nouveau drivers, the only way I got it to show a brief splash screen was using the latter. I’ve done some pretty extensive research through other topics, but I don’t have enough experience with xorg to really find the problem.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Parrot 4.10 x86_64 5.7.0-2parrot2-amd64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Boot ever live USB then install through GTK

Configured to multiboot with other systems? (yes / no)

No

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

acpi=strict in kernel, or Debian won’t boot on Lenovo

lspci | grep -i VGA
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (Whiskey Lake) (rev 02)
02:00.0 VGA compatible controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] (rev a1)

xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x43 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 1 associated providers: 0 name:modesetting
Provider 1: id: 0xd4 cap: 0x2, Sink Output crtcs: 4 outputs: 1 associated providers: 0 name:modesetting

Still haven’t solved this. Anyone?