Fingerprint Issue

Hi, I have Hp 450 G8 having a fingerprint scanner the question is how do I enable it on parrot os???


OS: Parrot OS 5.0 (LTS) x86_64
Host: HP ProBook 450 G8 Notebook PC
Kernel: 5.14.0-9parrot1-amd64
DE: Plasma 5.20.5
CPU: 11th Gen Intel i7-1165G7 (8) @ 4.700GHz

Hi. Check the model of your fingerprint and see that the drivers exist. Some fingerprints may be closed source and therefore not available (you should see it with lsusb command).

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 04f3:0c5e Elan Microelectronics Corp. ELAN:ARM-M4
Bus 003 Device 003: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
Bus 003 Device 007: ID 04ca:0061 Lite-On Technology Corp. USB Optical Mouse
Bus 003 Device 002: ID 30c9:0010 Luxvisions Innotech Limited HP HD Camera
Bus 003 Device 005: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Fingerprint… What is the second one??

This is your fingerprint sensor. I’ve checked and it seems it’s not supported yet.

Wifi AX201 : Not supported
Microphone : not Working
Fingerprint : Not Supported

Do you think Parrot 5.0 will solve all these issues with kernel 5.15???
Any Idea??

Wi-Fi is supported, you have to Google the driver model and download it and then install it manually.

I spend nearly 2 weeks on this problem and then someone told me to wait for Parrot 5
They said I have very new hardware (11 Gen)
I asked my question everywhere Telegram, FB, This website etc
So, waiting for parrot 5 : )

here is my QUESTION

I remember you also helped me but my problem was not solved

As I said above, you should try to google things. It is a very popular WiFi card.

By the way, I think this can help you. In the “firmware” section you should have the answer to your question: en:users:drivers:iwlwifi [Linux Wireless]

Which one I should download

Please guide…

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

I updated my firmware by downloading and copying this to /lib/firmware but wifi still not working

Have you already tried this?

yep I created a topic on this again please view