Fresh 4.7 Install Dropping to Initramfs

Briefly describe your issue below:
After freshly installing 4.7 on my thinkpad T450, whenever I try to boot the system normally, it drops to initramfs and when I press esc during boot to see the verbose output, I get greeted with a bunch of error messages.

Any ideas? I’m currently installing 4.6 from the iso again and trying to do a parrot-upgrade see if that works.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Parrot Security 4.7

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK

Configured to multiboot with other systems? (yes / no)

Looks like something went wrong while you were partitioning. Can you boot into a live OS and give us the output of the following command?

sudo fdisk -l

Just wanna make sure if /dev/sda3 really exists.

Install it from live mode. Boot into live mode, goto Applications>System Tools> install option. Same steps as GUI installer. While copying data to disk it will throw an error while configuring package manager. Ignore that and proceed to install grub to disk. After installing grub, exit the installer wizard and go back to live mode. Open Gparted, select boot partition and parrot system partition(one by one), right click and perform ‘check’ operation. After that reboot to system.


Just as an update, I’ve managed to install 4.6 and updated it using parrot-upgrade. Should I clean install 4.7 again or should I just stick with a 4.6 to 4.7 upgrade?

I did that a while earlier and it does indeed list /dev/sda1 as the EFI partition, /dev/sda2 as what I assume is the /boot and /dev/sda3 which is /. I also tried fsck as suggested by a few posts online and it kept giving me an error about a superblock. Either way, I installed

No need to reinstall, just dist-upgrade it. Try the above method if you want to clean install 4.7.

Alright, I guess I’ll just dist-upgrade it. I tried clean installing 4.7 from the downloaded iso as well on a VM in my vmware workstation and the same thing happens, could it be an issue with the downloaded iso?

Nope, it’s due to some issue in installer script. ISO is fine.

Ah should I raise it to the dev team to look into it?

1 Like

The problem was reported to whole team yesterday. We found the bug and we are working on it.


As a workaround this worked for me Parrot OS fails to load after GRUB

1 Like

wow … thats great … so im not creazy … lol …

thanx … great service

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.