Grub boot errors, not saving settings

Hey all,

I’m currently working on getting parrot running on my thinkpad e480 and I’ve had some troubles with grub. I can get grub to boot, but only through the cli. I found instructions to fix and boot into parrot, but when I run sudo update-grub, these settings are not saved and I have to repeat the process every time I boot my computer up.

What can I do to insure grub is configured correctly and prevent this from happening? I have parrot installed on various other machines and this issue has never occurred. Could this be a problem with my current PC?

Thanks in advance

What version of Parrot are you running? (4.2 security, 64 bit)

What method did you use to install Parrot? (Standard installer)

Configured to multiboot with other systems? (no)

If there are any similar issues or solutions, link to them below:

(I used the first answer to reboot my computer)

If there are any error messages or relevant logs, post them below:

Sorry I can not help, but I’ve also been experiencing this problem when I either do a full-upgrade from Home 4.1 or when I tried installing 4.2 from ISO. Nothing I’ve found has helped yet. I’ll let you know if I do come across anything helpful though.

I am having the same issue. I was running Parrot fine, and I hit yes on the prompt to install updates. After that, my Parrot boots only to a GRUB CLI. I can boot it by using the instructions in , and after booting, update-grub and grub-install complete successfully, but they do not change the behavior. It still boots to grub prompt. I see this post was started just 22 hrs ago, and I’m the third to report. It looks like this is a thing. Please help.

1 Like

This didn’t work for me.

I posted the solution that worked for me on another forum post:

Then I had to do the solution @JetJaguar posted above.

1 Like

for some reason it worked once, after reboot again after updates (using the new parrotsec 4.2 fresh install), same issue with grub not saving the changes as @JetJaguar has mentioned.

Haven’t found a work around jet except to manually type in the commands at the ‘grub’ prompt to boot the system.

Didn’t have this issue in parrotsec 4.1 on same system.

1 Like

Using the following also works instead of typing all the commands at the ‘grub’ prompt. In my case my root partion is located on ‘hd0,gpt2’

#grub> configfile (hd0,gpt2)/boot/grub/grub.cfg


Found the problem.

So it seems that the GRUB menu is failing to load because it is reading an incorrect efi file in /boot/efi/EFI/parrot/

After booting into the system, do the following:

sudo -i (become root - be carefull!)

cd /boot/efi/EFI/parrot
cp grubx64.efi grubx64.efi.bck (for safety make a backup)
rm grubx64.efi
cp /boot/grub/x86_64-efi/grub.efi /boot/efi/EFI/parrot/grubx64.efi

Reboot your system.

So all my steps involving booting into live, mounting partitions and chrooting into the system might not have been nessasary, but for some reason grub-efi didn’t install at install (sometimes it does, noticed same thing happen in parrotsec 4.1) but at least the copying the correct .efi file works in the end.


Thanks very much. I couldn’t wait so went with an entirely different solution. I may come back to Parrot and try your steps later.

it works just fine, thank you all the time watched how I managed that I looked and yes it works

So I came back to Parrot. I downloaded the latest version yesterday, installed, and it did the same thing. Booting to Grub prompt. I used Super Grub Disk, which is pretty nifty in its own right, to get into the system. After setting up OpenVAS, I decided to try your steps above. I was a little leery because I thought the problem was a result of running updates, and should not be present in a fresh install. But by cracky it worked and it boots up fine now. It takes you to the intended boot menu which has 3 choices. Thanks again. So this problem will be affecting all new installs until fixed, no?

I see ParrotSec posted on twitter the following:

“Linux 4.18, firefox 62, metasploit 4.17.11 and many new updates are now available on our stable branch
we will release Parrot 4.2.1 soon to include all of them and fix the grub-efi bug that affected some of our users”

So I’m going to wait for the update then fresh install and see before I start customising my current system.

check out this youtube video