Need help. Problems with GRUB

Briefly describe your issue below:

What version of Parrot are you running? (include version, edition, and architecture) 4.2 home edition

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental) I used the standard installer from a bootable usb stick.

Configured to multiboot with other systems? (yes / no) No

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

So, after I installed parrot os home version I could not boot into the system it just says GNU GRUB VERSION 2 and something about minimal bash line editing supported and it wont let me boot into my new system.

I had the same issue.
This worked for me (boot the parrotsec live usb after wards)
The guide I used is for Ubuntu but works fine with Parrot.
In my case, my parrot install was on /dev/sdb (usb was on /dev/sda) so I had to use /dev/sdb where /dev/
dX was stated.

Best to do a ‘ls /mnt’ after ‘sudo mount /dev/sdXXX /mnt’ to make sure you have the correct file system of your parrotsec install

Once you are on the Live desktop, open a terminal and execute these commands : 

sudo mount /dev/sdXXX /mnt
sudo mount /dev/sdXX /mnt/boot/efi
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
sudo chroot /mnt
grub-install /dev/sdX

Note : sdX = disk | sdXX = efi partition | sdXXX = system partition

This was taken from here

Then when your still unable to boot it and get the ‘grub’ prompt (happened to me)

Follow @JetJaguar’s solution in this post:

Also see my solution in the same post (linked above) to fix the grub issue by copying the correct .efi file for grub to be able to boot.

1 Like

JetJaguar here. The simplest, but maybe not fastest way to fix this is to use Super Grub Disk to boot your image, then use Jargon’s steps to permanently fix it. If you’re already comfortable putting an .iso image on a USB stick (or even an optical disk) and booting from it, SGD will allow you to boot right into your Parrot. Once in, use Jargon’s steps and you’re home free. What I ended up doing was using a Mint live environment to make the SGD and Parrot USB keys. Mint has a USB formatting and USB image writing tools that are very simple and effective.


Thanks a lot guys, I had the same problem and it works now!
Using SGB as JetJaguar said is really simple!
I’ve tried to follow the instructions on your link but after executing the boot command, a message said that /dev/sda5 does not exists (but my parrot was installed on hd0,5 so it was strange), but with SGB it worked the first time.

May be something related to the fact that I’m making a dual boot with a previously installed windows but anyway, thanks again!

1 Like

sblk sudo mount /dev/sda2 /mnt
sudo mount /dev/sda1 /mnt/boot/efi
sudo mount --bind /dev /mnt/dev
sudo mount --bind /dev/pts /mnt/dev/pts
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt

grub-install /dev/sda

ls /usr/lib/grub/

grub-install --target=x86_64-efi /dev/sda
This solution worked and and recommend

1 Like

bug fixed!

1 Like

thank you but i bypassed the issue keep with the good work

if somebody still have issue with grub bootloder checkout this video