Install Issues Burning ISO to USB


(Citi) #1

I tried downloading ISO multiple times. I noticed twice file size was only 2.9G. I used Etcher, Rufus, and Disk something (can’t remember name right now). The files failed to extract. They got until the very end of the process before I got this notification. I am a brand new user and just stumbled across Linux. I was able to successfully install Linux Mint on my laptop. Watching vids on how to use properly, I stumbled across HackerExploit on YouTube and Omg I am sooooooo excited to use Parrot :parrot::grin: So imagine my disappointment as I keep getting these errors. I’ve read that it’s not good to use Virus software so I made sure to disable this the second time around. I think the first two files were corrupt, regardless of what I did because of the file size. So I then downloaded again and now the file size is 3.6 like the specs say. I’m trying to burn ISO file now. Let’s see what happens. But in the meantime, if I end up falling asleep and don’t get parrot installed- anyone reading this willbw a great help if you can answer a few questions:

  1. Does it matter if you download the ISO file from a Windows desktop to a usb, but then use USB to install Parrot on a Linux OS laptop?

  2. Does anyone know how boot from EFI settings that have options like this < . > < . > BOOT etc.etc?

Thank you for reading.


What version of Parrot are you running? 4.5.1 Security

What method did you use to install Parrot? I have not got that far yet, but I plan to install w Debian

Configured to multiboot with other systems? no

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:


(Aaryan Saharan) #2

1)No it doesn’t matter. All the same
2)Not sure but you can always install parrot os directly from the install.exe present in the iso file.


(Citi) #3

When you say install directly, do you mean that you DONT have to burn it to a usb?


(Citi) #4

Ok, here is some of my progress. So when I tried to download parrot on my desktop then burn to usb, it did not work. It is a windows desktop. So I downloaded from target computer and used etcher to burn iso to usb. I rebooted my computer. It booted up! Only thing now is, I am in “LIVE” mode. One step closer!


(Citi) #5

Now I am able to get to the install screen, bit it says no ethernet card detected. It’s asking to select a driver needed by my ethernet card. Trying to figure this out now.


(Nico Paul) #6

It sounds like you didnt change some of your bios settings


(Citi) #7

Yes, I have tried this many times. I am not too sure what all the UFEI settings are. But from what I’ve been reading, I installed TLP to manage the PCI and power management. It shows that my settings are off and ethernet not detected. I am trying to learn how to turn power management off for Pci. People have said that this helps.

I went to Intel’s webiste and downloaded the latest drivers. This did not help.


(Citi) #8

I don’t see exe file anywhere.


(Nico Paul) #9

Thats because you dont need to it doesnt exist. Youre not supposed to extract anything just diwnload 4.5.1 amd64 iso use etcher and after disabling safeboot secureboot and allowing boot from usb use the gtk install and stick to the defaults


(Aaryan Saharan) #10

Use usb installer


(Amzker Pro Hacker) #11
  1. Try to download 4.4 from official parrot website (parrotsec.org/downloads)

  2. Then make bootable USB Via etcher

  3. after install run update your system & you will be in parrot4.5.1

Yes please match hashes of your downloaded file with parrotsec.org given hashes

Make sure secure boot off

And parrot security version ISO size if more than 3.5GB


(Citi) #12

I wonder if I could do this with the ethernet problem I’m having? Maybe install an earlier version and trick it lol


(Amzker Pro Hacker) #13

Actually you just described Event Not error . So,
I can’t figure out what is problem yoy facing during install
Just describe what is real Proble


(Citi) #14

I made another post on this: No Ethernet Detected During Install