Internet only works when AntonSurf is running

Internet doesn’t work after the use of AntonSurf and now only works when AntonSurf is enabled

VERSION_ID=“5.0”
VERSION=“5.0 (Electro Ara)”
VERSION_CODENAME=ara

Currently Internet is only accessible when AntonSurf is running!

I’ve found the solution to this issue for anyone who is suffering from this issue do the following:

  1. sudo rm /etc/resolv.conf
  2. sudo ln -s /run/resolvconf/resolv.conf
    etc/resolv.conf
  3. Restart your machine and run sudo apt-get update && sudo parrot-upgrade

This issue was caused to me after running a upgrade while AnonSurf was turned ON, so anyone facing this issue please update your system with AnonSurf OFF in the future.

1 Like

Thanks for sharing this! Using AnonSurf sometimes results in problems with resolver configuration in Parrot 5.0.

For future reference, if @Schnitzy’s method doesn’t work for you, you may try the one below:

2 Likes

Wrong. Palinuro messed up the resolver configuration. AnonSurf just did it job, which can’t deal with messed up logic.

2 Likes

Post edited to give justice to AnonSurf :wink:

1 Like

Yes it has been bullied for years lul

Well joking aside, I wrote dnstool because there are too many users didn’t fking know how to open a text editor to write settings resolv.conf. It has been 2 years and nothing changed.

1 Like