Mate / kde-plasma conflict = anonsurf trouble [SOLVED]

While attempting to resolve my issue with getting anonsurf to work,i decided to try the enable at boot feature,in the gui,which,for lack of better words,bricked the device.
i was able to login via recovery to disable the feature,but,all attempts via normal logins caused the device bootloop.
whether that is a bug,or something only impacting my device because of other settings is beyond me,but i figured i would share it,i guess you can look into it if you feel the need…

oh,i did also notice when disabling enable at boot that the gui listed an issue with the tor port for its reason for not connecting,perhaps that can resolve my overall issue with connecting to anonsurf…?
if so,what should id do to fix it?
also,will using vpn’s create issues for anonosurf?
Parrot Home MATE ISO 4.10
Debian standard install
multiboot/ NO
hp 14-ac159nr

That is not anonsurf


I’m probably misunderstanding you,so i’ll ask for a bit more clarification…
are you saying that it’s not anonsurf causing the issue,and it’s something else?
if so,that is definitely possible,but,it didn’t behave that way until that feature was activated,and it didn’t stop until i logged in via recovery and disabled it.i’m basically just correlating to the last change made

here’s a screen shot if you need a visual of what i’m speaking about,but i believe you are saying that anonsurf isn’t causing the issue…?

regarding vpn usage,deactivating the vpn and trying to use anonsurf didn’t work in the past,but i’ll uninstall it and try again…

and if that isn’t helpful,will any of these assist you in helping me resolve the issue i’ve had with anonsurf.

Screenshot at 2020-08-21 14-15-40

i enjoy the platform,but if i can’t get it’s keystone feature running,i’ll likely have to consider changing distros,which i’m trying to avoid…

show your /etc/resolv.conf after anonsurf is enabled

Screenshot at 2020-08-21 18-25-10

It is fine. that is not problem of anonsurf

okay,well thats one less thing to worry about.
now its a matter figuring out what could be leading to the loss of connection once it is activated…?

do you all have some type of frequently asked questions list,that might limit the need to create more problems by allowing the user to focus on specific areas to resolve potential problems?
that seems to work for many of the larger companies like windows and mac,which also host forums similar to this.
so perhaps that might limit the need for you to answer repeat questions,that you likely have grown tired of answering…
all that aside,as the developer here,what would you recommend i do next?

did you enable any firewall when anonsurf is actived?

i don’t recall doing so,for the sake of anonsurf,but the firewall is enabled just out common practice.

okay,well,that took care of it.
i appreciate your patience,and thought something that simple would likely be the culprit…

it is a bit counter intuitive,no vpn,no firewall,it still seems a bit odd to be honest…
should i just be enabling a port for anonsurf to work with an active firewall?
if not,i’m also curious whether or not some type of script can be developed or ran to disable vpns and firewalls upon launching anonsurf?

Do you have any process / service that uses port 53?
Can you try edit config /etc/anonsurf/torrc.base and edit dns port to other port and try?

regarding port 53,Not that i’m aware of?
but to be honest,i probably wouldn’t know…

i’ve made adjustment to the firewall permissions in the past,via command lines,but my experience with what you are saying is very low.
this is definitely a situation where i would definitely need step by step instructions,that way i’m not messing it up …

use netstat to check all ports

okay,will do…

$sudo netstat -anp | grep “:53”
udp 0 0* 2732/tor
udp 0 0* 278023/brave
udp 0 0* 278076/brave --type
udp 0 0* 278076/brave --type

That’s what i’m showing for port 53.
another question i’d appreciate your advice on is the privacy pass browser extension.
anonsurf creates a lot of capatcha request,would you recommend that type of extension as a possible workaround,or do you feel will negatively impact privacy…?

That is not problem of anonsurf

Is this before or after you start anonsurf?

i wasn’t saying its an issue with anonsurf,i believe it’s just a result of using tor.
that particular extension seems as if it could be useful,so i was just looking for your thoughts on the matter.
i’m assuming i’m not the only person who runs into that,which really slows down and limits browsing,so if there are any other workarounds for limiting capatcha request,i’m all ears…

regarding the port question,i’m pretty sure that was done prior to activation,or shortly after .
i’m trying to recreate the results now, but i’m getting nothing back in response…?
i enter the same command,and the terminal simply goes to the next entry request without any results…

Sorry to keep bothering you with this,but,perhaps when you have time,you can inform me of what to do or look for regarding port 53?
i could be wrong,but having to disable the fire wall to allow it to work seems a bit risky,that along with no vpn, and you feel as if it is all hanging on by a thread…

a side note to that…
initially anonsurf worked pretty smoothly,better than expected actually…
but over the last few days or so the gui has become very sluggish,and at times,non responsive.
there are moments when its supposed to be activated and the gui drops off as if its not even there…
i’m sure i could give better descriptions,but hopefully some of this can assist you in assisting me…?