Monitor mode (kinda) not supported

Briefly describe your issue below:
So, it seems that my laptop wifi card doesn’t support Monitor mode, which is a LIE because I’ve already use it in Kali Linux and WifiSlax. This is what the terminal shows when I run

airmon-ng start wlan0

Found 3 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to run ‘airmon-ng check kill’

PID Name
1282 NetworkManager
1285 wpa_supplicant
3291 dhclient

PHY Interface Driver Chipset

phy0 wlan0 wl Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter (rev 01)

	(experimental wl monitor mode vif enabled for [phy0]wlan0 on [phy0]prism0)

And then when Irun
airodump-ng wlan0
ioctl(SIOCSIWMODE) failed: Operation not supported
ioctl(SIOCSIWMODE) failed: Operation not supported
Error setting monitor mode on wlan0
Failed initializing wireless card(s): wlan0

I then realised that tthere was a new interface: prism0 that worked OK with airodump as it says at the end of airmon-ng start wlan0

Buut when I try to run prism0 in some other programs like airggedon it says that prism0 is not a wireless card and that it doesn’t support monitor mode, so I don’t know what to do?

As you can see the wireless card is a Broadcom BCM4313 802.11bgn


What version of Parrot are you running? (include version, edition, and architecture)
LIVE 4.1 security edition x64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Not installed, is a LIVEUSB
Configured to multiboot with other systems? (yes / no)
nope
If there are any similar issues or solutions, link to them below:

https://community.parrotsec.org/t/monitor-mode-issue/997

What chipset do you have?
Kill those pids with airmon-ng check kill

idk what do you mean with ‘chipset’ but the Wifi chipset info is

Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter (rev 01) (info returned using lspci | grep -i wireless)

I kill those processes everytime I run airmon but it stills create prims0 interface with ‘no wireless extensions’

Try to set monitor mode manually:
sudo ifconfig wlan0 down
sudo iwconfig wlan0 mode monitor
sudo ifconfig wlan0 up

this is [quote=“g0rbe, post:4, topic:2959, full:true”]
Try to set monitor mode manually:
sudo ifconfig wlan0 down
sudo iwconfig wlan0 mode monitor
sudo ifconfig wlan0 up
[/quote]

this is the way of putting it in monitor mode via ifconfig and iwconfig, but probably airmon-ng is better as it does additional checks and it also asks the user to kill some processes that may prevent the interface to work properly

anyways both the options are great and do the right thing properly

2 Likes

this is what the console returns when i run sudo iwconfig wlan0 mode monitor

sudo iwconfig wlan0 mode monitor
Error for wireless request “Set Mode” (8B06) :
SET failed on device wlan0 ; Operation not supported

But the thing is, it DOES support monitor mode, I used it with Kali and Wifislax before with 0 problems

yes, i saw that your crad need to support monitor mode.
Please show me the output of sudo lshw -c network

Kill conflicting processes before running wifite
sudo iwconfig wlan0 down (doesn’t work on newer OS)
sudo airmon-ng check kill
sudo airmon-ng start wlan0
run iwconfig to check for prism0 which is the monitor
sudo airodump-ng prism0 (starts recording all wireless traffic)

I have the same network card as you. Works for me. Only monitoring software that doesn’t work for me is fern. All the rest do.

1 Like