MonoDevelop

Briefly describe your issue below:
History.

I installed some dependencies, but the one’s installed were newer, which usually shouldn’t be a bother. I am new to Parrot, I haven’t actually used linux for years on end, it was the Win10 that made me want to go berserk, but I am still a gamer, so it’s still installed on the stationary and this is installed on my lapdog. I started of using Debian back in 2002 or something, tested about 50+ distros, closer to a hundred, young and curious. The gentoo installation was 2 month’s of research, my favorite distro was Slackware, but I got lazy later on and have been installing Ubuntu back and forth since version 2 I think, Ubuntu has become too heavyduty on the simplest of applications, so I thought I would try out some new distros, like Parrot OS & Kali, Parrot won, tails is quite fun to have on a stick when I travel, but yeah the problem. I wanted to use MonoDevelop on Parrot OS. Seems like it don’t want to be installed on the distro though. Is there anything that I can do? I can’t remember that much of my Linux usage, since too many Ubuntu installs, so I have kind of lost all my accumilated knowledge since the past. Installing older versions should work… Right? How do I install MonoDevelop? Or should I just WINE Visual Studio? :stuck_out_tongue_winking_eye:

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
4.6 Home amd64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Standard via USB Stick.

Configured to multiboot with other systems? (yes / no)
No

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
sudo apt-get install monodevelop
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
monodevelop : Depends: libfsharp-core4.3-cil (>= 4.1.33) but 4.0.0.4+dfsg2-2 is to be installed
Depends: libglade2.0-cil (>= 2.12.45) but 2.12.40-2 is to be installed
Depends: libglib2.0-cil (>= 2.12.45) but 2.12.40-2 is to be installed
Depends: libgtk2.0-cil (>= 2.12.45) but 2.12.40-2 is to be installed
Recommends: libgtk2.0-cil-dev but it is not going to be installed
Recommends: xamarin-gtk-theme but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

think its not sooo easy … :frowning:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.