No external montior signal

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Kernel: 5.5.0-1parrot1-amd64 x86_64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
I booted into a live USB environment and installed from there

Configured to multiboot with other systems? (yes / no)
yes, windows 10

List your hardware specs to include make, model and firmware (when applicable):
PU: 6-Core Intel Core i7-9750H (-MT MCP-)
speed/min/max: 800/800/4500 MHz
Mem: 2272.6/32058.3 MiB (7.1%)
Storage: 931.51 GiB (1.9% used)
Procs: 245 Shell: inxi: 3.1.04
GPU: Nivida 2080 Max Q

If there are any similar issues or solutions, link to them below:
I have tried : https://docs.parrotlinux.org/info/gpu-drivers/ and what I could find on google but those were 2 years old

If there are any error messages or relevant logs, post them below:

The computer doesn’t even act like I have an HDMI cord plugged in. If I try to plug in my USB C hub that has a monitor attached to it via VGA I get a pop up that gives me options on what I want to do with the monitor but nothing happens and it won’t go away.

Here is my current driver(i think) : VGA compatible controller: NVIDIA Corporation TU104BM [GeForce RTX 2080 Mobile] (rev ff) (prog-if ff)

Logs:
sudo cat user.log | grep ‘nvidia’
Jul 20 13:53:17 michael-81uj bumblebeed[883]: [12117.162509] [ERROR]Failed to unload module ‘nvidia_modeset’ (ref count: 1).
Jul 20 13:53:17 michael-81uj bumblebeed[883]: [12117.162989] [ERROR]Failed to unload module ‘nvidia’ (ref count: 18).
┌─[mike@michael-81uj]─[/var/log]
└──╼ $sudo cat kern.log | grep ‘nvidia’
Jul 20 06:18:25 michael-81uj kernel: [ 11.838067] audit: type=1400 audit(1595240300.549:4): apparmor=“STATUS” operation=“profile_load” profile=“unconfined” name=“nvidia_modprobe” pid=823 comm=“apparmor_parser”
Jul 20 06:18:25 michael-81uj kernel: [ 11.838934] audit: type=1400 audit(1595240300.549:7): apparmor=“STATUS” operation=“profile_load” profile=“unconfined” name=“nvidia_modprobe//kmod” pid=823 comm=“apparmor_parser”
Jul 20 06:31:50 michael-81uj kernel: [ 7.430924] nvidia: loading out-of-tree module taints kernel.
Jul 20 06:31:50 michael-81uj kernel: [ 7.430945] nvidia: module license ‘NVIDIA’ taints kernel.
Jul 20 06:31:50 michael-81uj kernel: [ 7.464591] nvidia-nvlink: Nvlink Core is being initialized, major device number 246
Jul 20 06:31:50 michael-81uj kernel: [ 7.465676] nvidia 0000:01:00.0: enabling device (0106 -> 0107)
Jul 20 06:31:50 michael-81uj kernel: [ 7.465824] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
Jul 20 06:31:50 michael-81uj kernel: [ 7.613367] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms 440.100 Fri May 29 08:14:04 UTC 2020
Jul 20 06:31:50 michael-81uj kernel: [ 7.776397] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
Jul 20 06:31:50 michael-81uj kernel: [ 7.776402] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1
Jul 20 06:31:50 michael-81uj kernel: [ 10.953975] audit: type=1400 audit(1595241109.671:5): apparmor=“STATUS” operation=“profile_load” profile=“unconfined” name=“nvidia_modprobe” pid=835 comm=“apparmor_parser”
Jul 20 06:31:50 michael-81uj kernel: [ 10.953984] audit: type=1400 audit(1595241109.671:6): apparmor=“STATUS” operation=“profile_load” profile=“unconfined” name=“nvidia_modprobe//kmod” pid=835 comm=“apparmor_parser”
Jul 20 06:31:50 michael-81uj kernel: [ 11.923031] [drm] [nvidia-drm] [GPU ID 0x00000100] Unloading driver
Jul 20 06:31:51 michael-81uj kernel: [ 12.458584] nvidia-modeset: Unloading
Jul 20 06:31:51 michael-81uj kernel: [ 12.598629] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms 440.100 Fri May 29 08:14:04 UTC 2020
Jul 20 09:05:13 michael-81uj kernel: [ 9214.502905] audit: type=1400 audit(1595250313.219:61): apparmor=“STATUS” operation=“profile_replace” profile=“unconfined” name=“nvidia_modprobe” pid=45792 comm=“apparmor_parser”
Jul 20 09:05:13 michael-81uj kernel: [ 9214.534314] audit: type=1400 audit(1595250313.251:62): apparmor=“STATUS” operation=“profile_replace” profile=“unconfined” name=“nvidia_modprobe//kmod” pid=45792 comm=“apparmor_parser”
Jul 20 09:05:13 michael-81uj kernel: [ 9214.928000] audit: type=1400 audit(1595250313.643:64): apparmor=“STATUS” operation=“profile_replace” profile=“unconfined” name=“nvidia_modprobe” pid=45856 comm=“apparmor_parser”
Jul 20 09:05:13 michael-81uj kernel: [ 9214.993467] audit: type=1400 audit(1595250313.711:65): apparmor=“STATUS” operation=“profile_replace” profile=“unconfined” name=“nvidia_modprobe//kmod” pid=45856 comm=“apparmor_parser”
Jul 20 15:27:24 michael-81uj kernel: [ 13.090776] audit: type=1400 audit(1595273243.800:4): apparmor=“STATUS” operation=“profile_load” profile=“unconfined” name=“nvidia_modprobe” pid=814 comm=“apparmor_parser”
Jul 20 15:27:24 michael-81uj kernel: [ 13.090783] audit: type=1400 audit(1595273243.800:5): apparmor=“STATUS” operation=“profile_load” profile=“unconfined” name=“nvidia_modprobe//kmod” pid=814 comm=“apparmor_parser”

Thank you for your help!

Have you checked at
System>>Preferences>>Hardware>>Displays