No internet

Hey all . New to parrot , when i disconnect from the tor i have no internet. Period. I have tried to reset the services but no dice. Almost like tor is hiding my connection. Used live boot and i have internet, so long as i don’t connect to tor.

Hi @LeamonDrop

Your /etc/resolv.conf is probably missing or blank. It’s a DNS thing.

cat /etc/resolv.conf

Posted earlier on this group…

Hi @Masmer I’ve followed your exact suggestion & the problem still persists, the output is exactly the same as link 2. For some reason, I’m unable to write to file in nano/vim & add nameservers to resolv.conf file (see screenshot in link 1) & dnstool was unable to fix the issue. Any suggestions would greatly appreciated. Meanwhile, when anonsurf is turned on, I can access the internet. Once off, no access.

(see link 1: AnonSurf 4.0 changelog and roadmap - #11) & (link 2: Internet only working if anonsurf is running...? - #31 by y05h1)

Sorry that didn’t work. I know the dev(s) are working on it.

It was strange, my resolv.conf file was gone and it wouldnt let me reinstall it. I did a fresh install and life is good. I can connect to tor manually and through my vpn but if i use the parrot service it delete the file. My counter was to make a copy of the .conf file before i tried aynthing.