Parrot OS freezes on brand new lenovo legion 5i

Please complete our guideline for issue report or idea suggestion

If you are having an issue, please follow this

There are many kinds of issues: OS, software, server, … So you must know:

  • Server issues will be fixed after report and we verify the problem. There will be no update patch for you. It is server side.
  • 3rd party software / packages can’t be fixed by us. If we can spot the bug and have the fix, we will create merge request to original source and wait for their official version.
  • Life is hard. For bug/ issue, please make sure your topic is only one. Dont make developers be terrorists.
  • This is a rolling distro. Bugs and issues are expected. We recommend you have basic linux knowledge to deal with your system, so
    Usually we don’t support issues that user faces by using his system in a wrong way. If you are new to Linux, make sure you didn’t make any mistake:
  1. Basic Linux:
  2. How to not break Debian system: or
  3. If you are having some questions, your answers might be in here:
  4. Your issue might be solved before (StackOverflow is a temple), try this:

1. Your Parrot information

  • OS version: run cat /etc/*release
    Copy output here :
    $cat /etc/*release
    PRETTY_NAME=“Parrot GNU/Linux 4.10”
    NAME=“Parrot GNU/Linux”

  • Kernel version: run uname -a
    Copy output here
    Linux ServerAnton 5.7.0-2parrot2-amd64 #1 SMP Debian 5.7.10-1parrot2 (2020-07-31) x86_64 GNU/Linux


Or if you can’t do it, please tell us ISO version you downloaded.

** ISO information **

Version: 4.9
Desktop Environment: Mate
Edition: Home

2. If you have this problem after fresh installation:

  1. How did you create USB bootable?

    • Software was used to make USB
    • Steps of making USB bootable
      I made the USB bootable by using the Disks Utility in ubuntu.
  2. How did you install OS?

    • Debian installer or Calamares installer?
      Debian installer.

3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

Hardware information

- Your device name or output of `lspci`
    Copy output here
- Did you try searching info about this issue on search engine? Please write **No** or any URL to this issue bellow

4. How did you get this error? Are there any steps to procedure it?

1. This Usually occurs when i am Browsing the web and i click on the 2nd monitor(i have a dual monitor setup).
2. As soon as i click on any of the application on the second screen while browsing the web, Parrot OS freezes, Also the ctrl+atl+f1 does'nt work aswell.
3. And the only way to get things working again is to have a reboot, which is getting annoying.

5. Error log or screenshot

** Insert error log and screenshot here**

6. If you have any idea or suggestion about this issue please tell us

** Your information **
i think this has to do with my graphics card (Its Nvidia GeForce GTX 1650 Ti ) and because of that i am getting the error. i have a feeling that the graphics card has something to do with the error.

If you are having suggestion for our OS, please write it bellow

1. Current Parrot version and Parrot version you want it has

2. Its section and how it affects our system

  • Pentesting / Forensic / Malware hunting / Privacy protection / …
  • It is: AppArmor profile / software / system service / kernel module…
  • when user runs this / start that, it can do…

3. Any other information about this idea

Sounds like Nvidia. Reply with output from inxi -G if you would like to share more information on your Graphics card.

Here you go bro

└──╼ $inxi -G
Device-1: NVIDIA TU117M driver: nouveau v: kernel
Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
resolution: 1: 1920x1080~60Hz 2: 1920x1080~120Hz
OpenGL: renderer: NV167 v: 4.3 Mesa 20.2.3

1 Like

Also if this problem cant be solved here, can you please maybe direct me somewhere or to someone who knows how to solve this, because this problem is really getting annoying for me. I have been thinking about changing from Parrot os to something else for a long time now.

Personally, never had an Nvidia.

There is a page on Nvidia in Parrot Docs:

Here is a recent Nvidia problem thread (with sucessful outcome). May provide insight: Nvidia Graphics Card issue

Nvidias UNIX/Linux drivers page:

You may find helpful to search Google/DuckDuckGo for “Solved” threads containing your card name. Being that Parrot is based off of Debian, steps should be the same.

Up to you there. Being you have access to the same Linux kernel, switching distros won’t necessarily fix anything (unless it does the work for you). You can install same graphics drivers across distros.

Someone else with Nvidia may chime in with first hand experience. I suggest starting with the first link I pasted on getting proprietary drivers installed. And if all else fails you can try Nvidia’s forums as another resource.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.