Parrot OS grub bootloader problem


(Cromium Cr) #1

version of parrot: 3.9
architecture: amd64)
edition: security
installer: debian standard
storage configuration: guided partition with separate / ,/home, /var ,/temp along with a swap and ESP partiton
multiboot with other systems: no

I am having a GRUB bootloader installation problem. The GRUB bootloader would just install. Even the grub-intall pakages a re missing so i couldn’t fix it. I did manually installed GRUB on the ESP partiton by live booting ubuntu but coudn’t configure GRUB2 to launch parrot os

It will be a great help if someone can help me out

By the way if any developer is seeing this please fix the god dam bootloader in the newer iso


#2

Are you installing it on a machine/vm/external devices ? How did you write your iso on your flashdrive ?

The bootloader is working fine on 3.11


(Cromium Cr) #3

i used ubootnetin and i tried installing ti on my laptop

The bootloaded failed to install during installation so i tried to use the live session to install grub manually but i found that grub-efi-amd64 isnt intalled by default so i can’t chroot and install grub manually.

I even tried the iso image on virtualbox just to confirm and took a screenshot to confirm this


(Cromium Cr) #4

UPDATE
I manged to install parrot os finally. I used the GTK installed during installation and i dont know how it managed to load grub-efi-amd64 and install grub but it did so problem solved.

And Everyone please use Etcher to write the iso to USB.


#5

Same problem, I will check your solution! Hope this will help!>


#6

I had the same problem once.
you can fix this problem by installing grub manually from live os. or you can fix grub loader by using boot-repair.
just google it you’ll find it.
boot repair uses ppa repository. since parrot didn’t suggest us to add ppa repos you can download boot repair iso and create a bootable drive.


#7

from a USB stick or a CDROM?


#8

well it installed for me but did not boot after, and the mouse didnt work in the installer


#9

why do you need a mouse in installer? :thinking:
Mouse didn’t work for me either. I always use keyboard shortcuts while installing.
But when i tried to install parrot on virtualbox mouse pointer is working.
I think mouse pointer won’t work until synaptic touchpad driver installed in our computer. :thinking:


#10

the gui gtk installer normally has a working mouse in DEBIAN, this is supposed to be debian if the mouse doesnt work it means the installer is broken, and it is broken because debian and ubuntu install on my laptop just fine Parrot doesnt, PS the mouse pointer works fine on the debian installer.,(wheezy,Jessie and stretch had no issue) Please no stupid comments I would like this to work on my laptop so Iam providing information about things that dont work that should, hoping the devs can figure out why it doesnt install on things Debian has no issue installing on. It is obvious to me that they changed somethings in the installer they should have left alone. PS Devuan also has no issue installing on this laptop, again please no stupid comments Im providing info so this can get fixed. I put an image on a USB stick that image had no issue booting on my laptop(compat bios), from USB, but the same image, did not boot from a DVD,on my laptop(compat bios). I then took that same DVD, and installed parrot on my desktop PC without any issues(using the secure boot other OS, my laptop doesnt have other OS option. The only difference is the bios options on the 2 systems, on the laptop I have secure boot or compat boot. So it does not work without UEFI ,on the laptop that is for windows with the windows key and Parrot can not boot. Even though it selects the proper Grub with compat, or appears to select grub PC same thing Debian selects Parrot does not boot. I did read a post somewhere on this forum where someone said there was an issue with baytrail, having 32bit boot support for a 64 bit cpu, and that was the issue with parrot. PS yea everything works fine on Virtualbox, this is a real laptop im talking about so working in virtualbox isnt much help it doesnt work on the laptop<addressing the stupid above that has nothing to do with the issue.Stay focused on the issue the issue is Parrot does not install and boot on some systems<this is what we are talking about,not virtualbox, or VM ware or anything else


#11

boot repair did not fix the issue on my laptop, how about we get the installer fix instead of do this and try that?


#12

(I am very laymans, so I probably am not explaining this technically)
Dude I was having SUCH a hard time installing Parrot OS also. I thought about doing the boot repair that dracula was talking about but I am a chicken… I found something called ‘Super Grub2 Disk’. I followed the instructions from the website and it was so simply fixed. You’ll be instructed to make a live usb of SGD and once you boot that up it’ll give you a Grub bios. Select the distro you want to repair, it’ll force it to boot. I think from there you just go to terminal and update grub, update dist, and upgrade dist. I might have missed a step or something there, but it’ll all be laid out for you on their website. Hope this works buddy!!


#13

ohh your command was thoughtful…
this stupid installed parrot within a 30 mins. and you mr.genius struck with installer. :joy:

I’ve mentioned two options. did you try install grub from live iso.
Boot-repair won’t fix boot-loader problem by itself.
you’ve to run commands after the boot-repair analyse your boot loader as they suggest.

and mr.genius… if a installer works perfectly on virtualbox… then it’s not a problem with the installer.
it’s with a drivers that you have. that’s what i meant. seems you’re so brilliant to comprehend what i said. :rofl::rofl::rofl::rofl::rofl:


#14

since I’ve found that you’re so smart… and can’t able to install grub by using terminal.
and didn’t know about googling. (you’re so smart for that eh… :rofl::rofl::rofl::rofl::rofl:)
here is a link that explains how to reinstall grub on linux systems.

http://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd


#15

can’t you see he’s a genius. he knows everything.
I’m pretty sure he’ll do something smart. (like clicking the boot-repair till end).
and will complain it didn’t work.
he’s really smart… he’s complaining about mouse pointer didn’t work. :rofl::rofl:


#16

I actually did the same as you did, and managed to fix the grub problem. It seems the GTK installation is the best way to install Parrot OS atm. Thanks for your advice.


#17

In my experience Parrot OS dosn’t run sudo apt-get update during install which leads to the installer accessing a file that doesn’t exist. You can open a terminal and run it manually.


(Routavarvas) #18

I had same problem.
I have BIOS version, earlier I had dual boot Kali(on sda)+win8(on sdb)
wanted to try Parrot Os
booted from live USB and installed from menu => grup installation to /target/ failed
finished installation without grub
after installation was done, i installed boot-repair (that required some time+web connection)
https://sourceforge.net/p/boot-repair/home/Home/
select the DEB
download boot-sav, boot-repair, glade2script, glade2script-gtk (all .deb files)
install glade files first then -sav, then repair
in terminal I used
sudo dpkg -i DEB_PACKAGE
after installation I started boot-repair from menu and followed instructions.
installed grub to sda (other option would have been sda1 that was defined as /)
install success
reboot and it worked.


(Felipe Flores) #19

I want to test parrot, but I get the same grub Lilo not installing, but I am not an advanced user as many here seem to be, Is it possible that you guys can make a tutorial on how to do this step by step or should I walk away and never come back?. I don’t to disturb anyone, is just an inquiry.
I am testing in a small old PC 32 bit before I commit to a 64 bit rig got Parrot Studio which is what I need, so any detailed help is appreciated , it would be a shame not to experience all this work because I failed to test this distro, I install many ubuntu variants. mostly mint and Kubuntu for newbies, so I am not new to linux and this is a great chance to introduce it to pros that have asked me for a fine solution.


#20

I had the similar issues attempting to install ParrotOS 4.1 Security on my laptop as a dual boot - grub did not install, and of course it would not boot except in live mode…after an evening of digging and using a variety of less than social words & phrases,

I found a suggestion the following notes to install the ParrotOS Home version using the GTK install from the live boot menu. The “Parrot Install” from within the live version already running did not work, and the regular “Install” from the live boot menu. However using the GTK Install worked, though the grub2 menu does not come up at boot, I have worked around for this for the moment by changing the boot loader in the bios to the Parrot and have it booting up and running.

Now, I am looking to upgrade to the Security edition, or I guess install all packages that would upgrade to that level…anyone know the best way to do thais?

Full disclosure: I am still a relative noob with linux, and have been using 1 distro or another for about 3 or 4 years.