Shutdown issue appeard

After new update i got this message before shutdown:
A program is still running:
not responding!
I found this problem alos appeard at linux mint one year ago:
it got solved after a linux mint update.

my screenshot

Just one hour ago I note this same problem trying to restart my lap… before to start today I made a clean of tcache using

sudo du -sh /var/cache/apt/archives

sudo apt-get clean

then I made a clean for old kernels using

sudo apt-get autoremove --purge

Now everytime when I want to log out / restart / shutdown appear this messageProblem%20for%20fix

My system and lap details

OS: Parrot GNU/Linux 4.7 x86_64
Host: 20B7000HUS ThinkPad T440
Kernel: 5.2.0-2parrot1-amd64
Packages: 3798 (dpkg)
Shell: bash 5.0.3
Resolution: 1600x900
WM: Metacity (Marco)
WM Theme: Icy-Dark
Icons: maia [GTK2/3]
Terminal: mate-terminal
Terminal Font: Monospace 13
CPU: Intel i5-4300U (4) @ 2.900GHz
GPU: Intel Haswell-ULT
Memory: 1071MiB / 7734MiB

1 Like

Hi @nicefox and @m0t , we are currently working on this issue , thanks for your patient


Yeah same error after updating yesterday :frowning:

Have the same issue with my laptop hope a patch will be released soon in an update

I am facing the same issue too.
I thought the problem was with the kept back packages. still the problem persists even after installing those packages.
The Chromium and VLC are not working after the upgrade. not sure if some other programs also stopped working.
is it a bug? if it is, is there a patch available.?

I cannot shut down at all. Only on Power button .There is also waiting time after login, like freezing or something…


Yes, indeed.

The way around it at the moment of writing is to downgrade your Gnome Keyring but I guess waiting for the patch would be rather feasible option since the bug does not concern any major security threat to the system & Im sure parrot devs are working hard for a patch/workaround

Fingers Crossed

Thats a new one [as far as I know]. Maybe share some crash/error logs (if any) and share your device specs [Ram, CPU, GPU, lspci. Also, has the issue appeared recently or (silly for asking it, but just for the note) was this waiting time prominent issue.

Cheers :blush:

Sorry, I can shut down after confirming at-spi-bus-launcher message and click LogOutAnyway. BUT after that nothing is happening for 30secs and than it shuts down in regular way.
Issue with login is same -after inserting login credentials, nothing happens. Usually it enters system immediately, but now there is login background and nothing more. I can move cursor and thats it… Again, I must wait like 30secs and after that, desktop pops up.
I can live with it, but its annoying…

Please try reinstall chromium and vlc. We got lib error (conflict version) from Debian side and we are fixing it.

I think the last update solved the issue. can shutdown/reboot the system properly now.
I reinstalled VLC and chromium.
Thank you.

When you say

Now , you haven’t message from “at-spi-bus-launcher” ?

Hello @librebot :slightly_smiling_face:

So basically what you are saying is, your startup is slow.
It would be great if you would share your system specs like RAM, GPU, CPU, lspci & additionally Parrot Version & if you are multibooting any other Operating system alongside it.

A lot of start-on-startup applications may be causing this issue as well. Keep a note of the amount of those application.

Let us know,
Cheers! :blush:

1 Like

I experienced the same Issue that my login and logout is slow. It came with the gnome-keyring bug so I think its a temporary problem which should be fixed with the next release.

1 Like

No I don’t see the “at-spi-bus-launcher” message after the last upgrade.

and I don’t see any problem while shutting down or when restarting the system.

LoL you know, i always use shutdown command to shutdown or reboot machine and the error affected GUI only and i was like where the hell did the error happens. Can you show us your gnome-keyring version? Just confirm it.

Yeah ofc we update it as soon as possible. Our leader didn’t downgrade it because of security problems might have and version conflict errors.

And, in the funny way, the bug shows us gnome-keyring worked perfectly before LoL. Cheers!


Package: gnome-keyring
Version: 3.34.0-1
(from apt show gnome-keyring)

I think there is a bug when i click on shutdown (api-bus still happens to me) and i didn’t shut my machine down. Mate menu doesn’t take my keyboard type

I downgrade gnome-keyring but still get the error

Because it’s not gnome-keyring , fix is on Rolling-testing and we going deploy it , just be patient , this problem will be fix soon :wink:

1 Like