So many things wrong with my system

Hello, I’ve been into the Parrot OS system for quite a while but for some unknown reason , for the past 6 months I had a bunch of problems I coudn’t resolve.
For once , I recall turning on anonsurf and shutting off the system (terrible thing to do I know)
now when I turned it back on I couldn’t find anonsurf service anymore and I came to find out I don’t have any internet conneciton.
I tried doing a bunch of stuff , including trying to do
“sudo apt-get update” but it says “Temporary failure resolving dev.parrotsec.org” basically on everything I try to update or upgrade.
Also I run my Parrot on VirtualBox, and I did install guest additions but for some reason I can’t get bidiractional clipboard to work in any way possible.
please help me as much as you can :slight_smile:

It should be deb.parrotsec.org

We know that bug. We are developing new version of anonsurf and it is ready to use. The bug should be fixed in this new version.

Previous versions of anonsurf don’t work as service.

Check your DNS settings.

Maybe go have a look at this thread @Daniz51
https://community.parrotlinux.org/t/firefox-server-not-found/8791

1 Like

It is deb.pareotsec.org , it was a misspell

My DNS settings are fine as I see it … just that I found online the fact I turned on anon surf and did not disable it before shutting of the system down made my system not able to connect to the network

Here. Try to run this :

sudo anonsurf stop
reboot your system.

Let me know how it goes :slight_smile:

Says anonsurf not found

Check your iptables rules also.

Hello,

I assume the problem is your firewall if you are running.
One option is to stop your firewall,
The other one and the best thing to do is to make incoming option allowed because when you open it, default is in deny state, so you need to allow it to use anonsurf or tor services or any other connection services.

Thanks,
And please let us know whether you solve your problem.

20200203_030355

assuming its the iptables via ufw

run sudo ufw disable in the terminal

If that solves the issues, then audit the firewall incoming/outgoing ruleset.

sudo: ufw: command not found :frowning:

also iptables -L won’t load whatsoever …

I did

sudo pluma /etc/resolv.conf

and removed a weird IP I had there (192.168.28.43 or something like that) and added 1.1.1.1 and 1.0.0.1

also I tried pinging 8.8.8.8 and I get this : From 192.168.43.28 … destination host unreachable

also can anyone figure out why I can’t share clipboard from my VM to the host PC and backwards ? I’ve done everything…

Thats weird. What ever it gives out? Or are you able to load iptables --help If not, they are not installed/incorrectly installed/broken installation Have you ever played around it before?

Guest Additions. Are those loaded up and running?

image

loaded up and running but still…

update on the network thing: I just removed the Wired Network connection and it got added again and now I have internet access again

Do you know how to use the
Ifconfig
Command?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.