Unable to install Nvidia GPU Drivers

HI my first post was here and I was told to open second one if Im unable to install drivers.
https://community.parrotsec.org/t/problem-with-nvidia-drivers-installation/8130

After tried to insstall from here https://www.parrotsec.org/docs/info/gpu-drivers/

Im still unable to install them after command:
sudo apt install nvidia-driver

I got this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver : Depends: nvidia-driver-libs (= 430.14-1parrot1) but it is not going to be installed or
                          nvidia-driver-libs-nonglvnd (= 430.14-1parrot1) but it is not going to be installed
                 Recommends: nvidia-settings (>= 430) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Would be so happy if anyone can help me even Via team viewer I’ll tip you $5 via BTC. Thank you.

There are a couple of ways to go about this. First I would try the following commands:

┌─[tobias@parrot]─[~]
└──╼ $sudo dpkg --configure -a

or

┌─[tobias@parrot]─[~]
└──╼ $sudo apt install -f

Hopefully that helps with the installation process, by meeting the dependencies. If not, try downloading the dependencies that you are missing manually from the links below:

nvidia-driver-libs (390.116-1)
nvidia-driver-libs-nonglvnd (390.116-1)

Hopefully this helps!

BTC:
3J1GXGkzMQm4SNjEBPPcEkAoZouh5j9qHz

please think about to support the project and the community … not payed support between users!
:wink:

Hi, i would suggest you run:

sudo apt purge nvidia
sudo apt purge bumblebee* primus
sudo apt autoremove && sudo apt autoclean

Like this you will start freshly, then:

sudo apt update && sudo apt insall nvidia-driver
sudo apt install bumblebee-nvidia primus

Then it should be fine.

You don’t need to pay us for help, we are an open community, we are here to help each other.

3 Likes

Thank you for your help. How I can check now (which command) if my driver was installed successfully?

Thank you.

Try running something with with optirun, i. e.:

optirun nano

If the text editor open’s and there are no errors in the log, check if bumblebee deleted nvidia drivers after you closed text editor:

lsmod | grep nvidia

If this outputs nothing, then everything is ok.

2 Likes

It’s seems that I don’t have installed any drivers.

“optirun nano” gives a:

optirun nano
[94153.421917] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[94153.422042] [ERROR]Aborting because fallback start is disabled.

and
lsmod | grep nvidia, gives no any text, just nothing.

I would be very grateful if someone help me to install this driver.

Thanks a lot.

The drivers are installed, bumblebee unload the drivers when the gpu is not used and thats why lsmod doesn’t sees it.

I need to check a few things before i can help:

  1. Have you done your update by running “sudo parrot-upgrade” recently ?
  2. What does “uname -r” gives you ?

if answer 1 is yes and answer 2 is “4.19.37-parrot1-amd64” then you might need to install older nvidia driver.

1 Like

Please open an additional terminal and run in the main one optirun nano, and in the second one sudo journalctl -xe | grep bumblebee and post the output.

2 Likes

Sorry guys for late reply I am on a holiday. Yes my system is fully upgrade.
So commands gives this:
‘uname -r’
“5.1.0-parrot1-3t-amd64”

‘optirun nano’
[48396.350072] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
[48396.350171] [ERROR]Aborting because fallback start is disabled.

sudo journalctl -xe | grep bumblebee
Jul 12 11:36:21 parrot bumblebeed[800]: libkmod: ERROR …/libkmod/libkmod-module.c:832 kmod_module_insert_module: could not find module by name=‘off’
Jul 12 11:36:21 parrot bumblebeed[800]: [39168.980968] [ERROR]Could not load GPU driver
Jul 12 14:10:08 parrot bumblebeed[800]: libkmod: ERROR …/libkmod/libkmod-module.c:832 kmod_module_insert_module: could not find module by name=‘off’
Jul 12 14:10:08 parrot bumblebeed[800]: [48396.349956] [ERROR]Could not load GPU driver

Thank you for any help.

Ok that’s an old bug, open /etc/modprobe.d/blacklist-nvidia.conf with your favorite text editor and put # on every line that contains ‘off’. Mine is looking like this:

# Do not modify
# This file was generated by nvidia-prime
blacklist nvidia
blacklist nvidia-drm
blacklist nvidia-modeset
#alias nvidia off
alias nvidia-drm off
#alias nvidia-modeset off
2 Likes

Hello. I’m totally new myself and experienced big problems with NVidia on a laptop. After some research and multiple failed attempts, I found that following guide helped me.


It is for Kali Linux, but works as a charm. Only thing you need to do, if you are using lightdm is follow the guide until the line when he mentioned Grab the GDM/XDG Autostart file: and do following:

LightDM

For the LightDM display manager:

/etc/lightdm/display_setup.sh

#!/bin/sh
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

Make the script executable:

chmod +x /etc/lightdm/display_setup.sh

Now configure lightdm to run the script by editing the [Seat:*] section in /etc/lightdm/lightdm.conf :

/etc/lightdm/lightdm.conf

[Seat:*] display-setup-script=/etc/lightdm/display_setup.sh

Now reboot and your display manager should start.

I’m not sure if this method is the best, but it worked for me.

1 Like

@hotwater
I don’t have such file mate:
cat: /etc/modprobe.d/blacklist-nvidia.conf: No such file or directory

@Gerda
After command: apt install nvidia-driver nvidia-xconfig
At the end of installation I got some errors I paste them to text:
pastebin.com/jPR9ixiw

Thanks guys for any help hope we will fix that.

Create one :wink:

1 Like

@hotwater
After creating a file /etc/modprobe.d/blacklist-nvidia.conf
and your settings @hotwater
I got this after command: journalctl -xe | grep bumblebee
https://pastebin.com/ddwJ80jp

Thank you.

We already have a modified guide here: https://www.parrotsec.org/docs/info/gpu-drivers/

Install xorg mouse module:

sudo apt install xserver-xorg-input-mouse

And try again.

I still get op error. Can’t even install nvidia-drivers package after doing dpkg configure, apt install -f, or trying to fix packages with synaptic (yes i read the doc but the first step pretty much asks to install nvidia-driver that leads to current error). Did the purge steps, parrot upgrade, and i’m in the latest version.

Edit: Turns out that if you run sudo apt install nvidia-settings first, you’ll avoid the OP error and install nvidia-driver successfully.