Xorg.0.log & Screen Tearing

I noticed that my “Xorg.0.log” was filling up and noticed is was the same lines being repeated.

[ 1326.145] (EE) modeset(0): Failed to get GBM bo for flip to new front.
[ 1326.145] (EE) modeset(0): present flip failed

In a previous thread, they work around was to change the “Windows Manager” setting to “Macro (No compositor)”. This does stop the logs, but does cause an annoying flicker when in a terminal from backspacing all the way to the prompt. You get the chirp, plus a nasty flicker. However, if you set it to
"Macro (Compton GPU compositor)", then you do not get the flicker or the excessive logs.

Kernel: 5.1.0-parrot1-3t-amd64 #1 SMP Parrot 5.1.3-1parrot1.3t (2019-05-20) x86_64

Previous Thread --Self-reseting to loging screen

Fix actions:

  1. System > Preferences > Look and Feel > MATE Tweak

  2. Under “Windows”, chage the dropdown to "Macro (Compton GPU compositor)"

  3. Bring up “Log File Viewer” and look at the “Xorg.0.log” to make sure there is no more logs being created

2 Likes

excellent find - I had just posted about this “bug” after a search on our forums initally came up empty.

No problem. Figured I was not the only one.

1 Like

Thanks. Yeah IDK what is going on with the compositor, but it looks like it has been around for a while.

Ubuntu Mate Tearing

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.