Internet stop working after I've started ANONSURF

Question for you…

what would cause wifi only to work when a vpn client is running?
while trying to trouble shoot my (perceived) issue with anonsurf,i disabled my vpn client,just to see if there was still connectivity,be it unsecured…?
well,turns out the answer is no…
so i turned on another windows laptop,did the same thing,and got the same result…
so clearly the for me,anonsurf likely isn’t the issue at all,anonsurf just isn’t able to connect to wifi system once it’s activated…
this much i can understand,and obviously something is reconfigured, but how can determine what that might be and resolve it?

The testing version should work without tor -f. And it should work with sudo service tor start if tor coulnd’t start.

If tor can’t start:

The command sudo journalctl -b -u tor@default.service shows you debug log of tor so if you capture the output, i can get the error log and guess what was wrong.
P/s: I would like to have both error log of current version on repo and testing version.

I don’t understand what was your problem.

At the moment,i’m not able to connect to wifi without the vpn client active.
i’m thinking this may be what is prevent anonsurf from connecting…?
my guess is that when anon surf is activated it likely tries to disable the vpn,or perhaps a network configuration error within my system becomes apparent when it tries to connect<which lead me to test it with anonsurf,and vpn disabled,that when it became obvious there was something else potentially causing the problem,and not anon surf…

my question to you all is,what can cause this type of behavior?

this article is the only one i’ve found of something similar,perhaps it better explains…

i just tried again but this time its returning
2020-06-30anon-status unable

also no errors in sudo journalctl -b -u tor@default.service output


using test version
anonsurf latest pkg 2020-06-30

if you press page down or enter in journalctl you can view the next part of error log

I go to 4.9.1 live mode and 1 error of the version on repository is /etc/tor/torrc is missing. Live mode. This is 1 of problems

Newer version with new My IP check, random hash (the authentication is not working for some reasons).
https://nest.parrot.sh/packages/tools/anonsurf/-/jobs/1979/artifacts/download

thanks for telling

output:




still getting (using test version)
2020-06-30anon-status unable

Oh shit this is something about connect tor tor network and i’m afraid i can’t do anything. More like Tor nodes are being blocked.

Finally got it working after turning off firewall
issue : https://github.com/coldhakca/tor-relay-bootstrap/issues/5
nyx/anonsurf status

but i upgraded the my system before this and it showed me that this will downgrade Anonsurf

anyway Happy that it’s working :smiley:

You must be shitting me :rofl: :rofl: :rofl:

Yes it uses official version on repo
I’m reworking current features of anonsurf. When i complete i’ll check the firewall compatible settings and apparmor hardening.

1 Like

Switch the “change” to “changeid-auto” which uses Tor control port now. No need to use any sudo or restart tor service.

1 Like

no ,comparision below
firewall on


firewall off

Nice :+1:


*off-topic
2020-07-01-dmk-pim
:thinking: angry on someone?

Anonsurf never works with any firewall on
The msg was about amdgpu driver doesn’t work on Parrot.

1 Like

Newer version is building include fix for the authentication (in previous version). Now everything works out of the box. I’m checking the changeid to see if the enter country code works for tor

1 Like

Any test case / report please go to here

Hi,
Just wanted to thank you for this post. Was already searching for hours what the problem could have been. At first i thought it was a DNS issue. Because i was able to ping but not to resolve names.

So i guess you are having problem with anonsurf? can you please try our latest AnonSurf from https://nest.parrotsec.org/packages/tools/anonsurf/ and see if it work

This works perfectly.
Thanks Jean-bon for mentioning clear solution.