Multiple issues after upgrade

I’ve installed the latest update for my system (using the Parrot GUI which asked me if I wanted to do it).
Since I rebooted, my system is not working properly and I’m having some issues I have already had before.

The issues:

  • Shutdown is not working, it freezes on the loading screen.
  • Pressing the physical shutdown button just halt my computer instantly, without any prompt (I say instantly like really, as if I just unplugged the computer)
  • The touchpad is not working, the clics are ok but I can’t move the mouse. My external mouse is working fine.

What I did before to solve them:
I’ve tried before to install the Bumblebee drivers for Nvidia (here) but then my computer started on the command line interface, and I wasn’t able to start the graphical one. So I reinstalled the system.
I tried the old method (here) and my system was not booting anymore. I had to add “acpi=off” to boot options to make it work. Then, when it finally boot, my touchpad was working (WTF??) and it also fix the shutdown issue. But since the upgrade, it’s not working anymore. I’ve tried to reinstall the package, still.

My computer is a 2016 Razer Blade, with an Intel graphic ship AND a Nvidia graphic card, I think it might be linked to my computer, but I can’t figure out how to fix this as I’m a beginner with Parrot and linux.

Can anyone help me to find out what cause that and how to fix it permanently? Thanks!

What version of Parrot are you running? Parrot Security 4.2.2 x64 on a Razer Blade 2016

What method did you use to install Parrot? Debian Standard

Configured to multiboot with other systems? Yes, Windows 10 installed first, then Parrot

If there are any similar issues or solutions, link to them below:
I’ve already faced theses issues, without being able to solve them (I just reinstalled the system):

If there are any error messages or relevant logs, post them below:

Whats your gpu?

It’s a Nvidia GTX 1060

I believe you would use the vulkan/mesa drivers like the 1080 (i reccomend double checking the nvidia forums to verify the vdpau, cuda and other versions) and then you may have to edit your xorg config at /etc/X11/xorg.config as well to load it when xserver starts

1 Like

I don’t understand why I should have to do this as it worked before with the nvidia-driver? And I don’t understand how this driver is linked to my touchpad problem… It doesn’t make any sense to me but as I said, I’m new to all of this.
Anyway, I don’t even have a /etc/X11/xorg.config and I don’t know how it’s supposed to work, but when I start Nvidia X Server, a message tell me that it does not appear that I’m using the Nvidia X driver.

you dont have to use an alternative to the preloaded nouveau, it works to display just fine but not use GPU for processing power. do you have a /etc/X11/xserver.config? Nvidia and xserver are two different things, Perhaps you have changed desktop environments from the default xserver and thats why the display isnt working because the location of the name of the nvidia driver has changed? I use a desktop so there may be other things about touch devices that may apply that i am not knowledgeable enough to speak on.

1 Like

That’s what i thought, but I wasn’t able to make the computer shutdown properly with the default driver, only with the one I installed (nvidia-driver).
However I don’t need to use my GPU for processing power right now. If there is a way to tell the system to use the Intel graphic chip and if it should be more simple than trying to make my Nvidia card working, I’ll be happy to go with that…
For your question, no I don’t have the xserver.config file either (the only .config file in this directory is Xwrapper.config)

Well actually I solved the issues by removing the acpi=off option from my boot config (option that I added in the first place to make it work…)
So everything’s fine for now, I hope it will be even after the next upgrade :smile:

Thanks for your help and your time @Nico_Paul!

That setting for the integrated graphics should be in your BIOS settings (at least it is for Gigabyte) not sure what is for razer but I assume it’s the same. You may need the extra bios packages from synaptic as well but I’m not sure

I apologize as I didn’t comment anything about the shutdown issue (I know you said you had gotten it to work but if you run into the issue again in the future for whatever reason I have read (and I did it on my system as well and dont have any issues anymore where as before I actually thought all the text was normal in linux) that you should disable intel rapid storage technology as it is problematic (I can not speak for experience as I did that before I even live booted).

1 Like

Thanks for that advice, I’ll take a look at it!

1 Like