Parrot OS fails to load after GRUB

Briefly describe your issue below:
Parrot OS installation is completed however i’ll start up my laptop after removing the installation the grub menu will show and I’ll select parrot os, then a grey screen with three loading boxes appears and the BusyBox (initramfs) terminal appears instead of Parrot OS. I included the following errors it displayed in the photos below. A similar issue happens when I do it using the GTK installer.

What version of Parrot are you running?
Parrot Sec 4.7, AMD64, thinkpad T420

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
USB iso burned with Balena Etcher, used the legacy boot option in bios and did standard text install, then attempted Debian GTK with uefi, then did standard text install with uefi. Have tried almost every possible install option with the USB and with the ISO burned on a DVD

Configured to multiboot with other systems?
No

If there are any similar issues or solutions, link to them below:

Parrot OS not booting after Installation - Similar issue only the “fsck” command is not found

If there are any error messages or relevant logs, post them below:

Pictures:

https://drive.google.com/folderview?id=1-3abwtsAopGhlO9-cUMhFQ2o8Zgq6aVN

1 Like

I had the same problem with a asus laptop, all installations ended in initramfs. Exit in initramfs also gave “Alert! /dev/sdaX not found”. With googling I found that the problem was that no modules were loaded in initramfs (cat /proc/modules gave nothing). The (not ideal) solution that worked for me was to boot into the live cd/usb version and mount /boot. Then I copied THE LIVE CD version of /boot/initrd.img-xxxxx into /boot/ on the systems harddrive. Make a backup of the old one first. After this I rebooted and it booted into parrot. I think there is a better way to make the correct modules load but this worked for me :man_shrugging:

Hope this helps

2 Likes

THANK YOU SO MUCH
That was a really clever solution, you just made 3 days worth of reinstalling Parrot OS in every way and form worth it!!!

Your fix worked perfectly however the only issue I encountered was being unable to mount the boot folder in the terminal as it it said it could not find it. So I used Caja but I still could not find it there. So I went ahead and rebooted the live but this time in UEFI mode and sudo caja was able to find it and I was able to copy the initrd.img using caja.

So for people trying this fix try it in UEFI first :smile:

Having this same issue, it drops into the intramdfs every time, i am able to use the live boot off my usb fine. For the record i am trying to install it on a cheap laptop thats using mmc for it storage… I am not sure how to fix this if you could give a command by command example that would help so much.

Here is what I did in a step-by-step way:

  1. Install Parrot os from live usb/cd as normal, reboot and it drops into initramfs.
  2. Check that it is the same issue by typing exit in initramfs, it should say “Alert! /dev/sdaX not found”
  3. Boot back into the live cd/usb in the live mode so that you get the desktop.
  4. Open Caja and on the left hand side you should see Computer with Desktop, File System etc (This is the live environments files).
  5. In this menu go to File System -> Boot and you should find a file like initrd.img-xxxxx. Copy this file.
  6. On the left hand side in Caja beneath the Computer section you should see ex. /boot, /sda3, /parrot-syste or somesuch. Go to the /boot
  7. In this folder you should see similar files to the File System -> Boot. Rename the initrd.img-xxx in this folder to backup_initrd.img-xxxx and then copy the earlier file to this folder.
  8. Reboot computer and it should hopefully boot into Parrot after GRUB. As superawesome323 said you might have to enable UEFI in BIOS if it is in legacy mode.

Cheers, hopefully i did not miss a step.

2 Likes

We’re working on it and fix will be shipped in next updates.